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OVERVIEW
We wrote these programs to aid in the running of our digital exhibition (salon). We are providing them for free to others 
that may wish to use them. However, a $50 donation would be appreciated, see page 4. Latest versions are at:
http://www/mattman944/SalonSoftware/

This collection of seven programs will greatly reduce the time required to run a digital salon. However, a high degree 
of computer proficiency and organizational skills are still required. Also note that these programs are only useful 
for digital salons; they will be of little use to someone running a traditional slide or print salon. Finally, if you need 
software for a club, there is another program that is better suited for club and interclub competitions: 
http://www/mattman944/ClubViewer/

The Salon programs will do the following:

1. Collate the entry forms into a master image list file.
2. Sort the images by section or other criteria.
3. Display the images sequentially for judging.
4. Allow scores to be entered manually or directly enter the judges’ scores into the database if a compatible judging 

system is used.
5. Create a mailing list for mailing CD catalogs.
6. Create report cards.
7. Create traditional salon acceptance text.
8. Create a results table for the Star Ratings Director.
9. Generate statistics.
10. Create HTML results pages for posting results and images on the Internet or a CD.
11. Create reduced images with names and titles added for a slide show. 

The digital salon must be setup from the beginning using the guidelines required by these programs. Your entry forms 
and rules must follow the required guidelines.

The programs can currently handle 6 sections, 4 images per section, 2500 entrants, and 20000 entries. Your computer 
memory may limit the total entries to less than this. Older versions of the programs (prior to 2010) were very slow when 
opening large files or sorting if the number of entries was above a few thousand. Be sure to get the latest versions.

These programs require that the entry forms be submitted via the Internet. Images must be submitted electronically, 
either via a website, email, or by mailing a removable disk or CD. Your Salon may choose to limit the methods that can 
be used to submit images.

We have included a set of practice entry files and images. We recommend that you use these files to test the programs 
and become familiar with them. Example output files from the programs are also included to allow you to view an 
example output file without running the program and to allow the programs to be tested in any order (some programs 
require output files from other programs). It is OK to overwrite the example output files when testing; the originals are 
in the original zip file.

We have used the slang term "salon" in our instructions and programs. "Exhibition" is the preferred term to use in Entry 
Rules and Catalogs.

The formats for all the data files is included if you would like to implement a more sophisticated entry form and image 
submission method yourself. Likewise, you may wish to make reports or slideshows in a different manner.

The instructions are divided into two sections:
- General Operation
- Detailed Instructions
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REQUIREMENTS
1. PC compatible computer. Tested on a 500 MHz Pentium. Will probably work on any Pentium computer.
2. Tested thoroughly on Windows XP, some testing on Windows Vista and Windows7. No reported issues on 

Windows8, although I haven’t used it yet. Should work on Windows 95 or later. Windows 98SE or later required 
when using the H-ITT infrared clickers. Windows XP or later required when using the RMF Model 750 Judging 
System.

3. Enough free disk space on your computer to hold the programs and entries. The programs and sample files only 
require about 20 Mbyte of disk space. However, the images from each entrant will average about 1 Mbyte per 
section for 1024 x 786 images; can be much more for larger images. 

4. Graphics card and monitor capable of displaying 1024 by 768 pixels.
5. Microsoft Expressions Web, Adobe Dreamweaver, or another webpage editor that has a “form” output compatible 

with “Microsoft Frontpage Extensions”. I believe that these are now integrated into the HTML standard.
6. Website to put entry forms and instructions. To use the supplied entry forms, the server hosting your website must 

be running PHP. Check with your service provider. See separate instructions for using the entry forms.
7. Computer skills to create webpages.
8. Email for receiving entry files. A separate email address for the Salon is recommended.
9. Microsoft Word or another program that has a “Mail Merge” function.
10. Second computer on judging day (unless using a compatible judging system, then only one is needed).

RECOMMENDED
1. Computer LCD projector capable of displaying 1024 by 768 pixels on judging day.  
2. Adobe Acrobat (full version) for creating entry instructions. Acrobat is the most universal program for creating 

files that can be read by any computer. The Acrobat reader is free; the full version for creating files must be 
purchased from Adobe.

3. Microsoft Excel or another spreadsheet program.
4. Microsoft Word 2002 or another program that can do an email merge.
5. High speed Internet connection. The images from each entrant will average about 1 Mbyte per section. Receiving 

all of the images with a traditional telephone modem will be very time consuming.

CONDITIONS FOR USE
1. These programs may only be used for PSA recognized salons.

INSTALLATION
1. Unzip the "Salon Software" folder to your hard drive. Navigate to the folder where you would like the files placed 

(recommended folder: “My Documents”). See the recommended folder structure in the next section. The programs 
do not require a normal installation procedure. None of the programs write to the registry or place files in any 
Windows system folders.

2. If you are using the H-ITT infrared clickers to score, see separate instructions to install the drivers at the end of this 
document.
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FOLDER STRUCTURE
The recommended folder structure is below. Make a new folder within the Salon Software folder for each Salon 
exhibition. 

Suggested folder structure:
  -  My Documents

- Salon Software
- Programs
- Sample Entry Rules and Forms
- Sample Entries and Images
- Sample HTML
- Sample Slideshow
- PSA-EID Standards and Forms
- H-ITT Clicker Drivers
- Salon 2005
- Salon 2006

All of the entries for a Salon must be in the same folder.

SUPPORT
1. We will be glad to provide limited support as our time allows. However, if the support becomes a burden to us, we 

may ask for consulting fees. We will supply support more generously to those who have contributed to the EID 
division or helped us with our Salon.

2. Bugs: please inform us of any bugs you find. Please include the program name, the version of the program you are 
having problems with (under Help->About), and explain the problem in detail.

3. New versions: check our website to see if there is a newer version. 

http://mattman944.com/SalonSoftware/

Nick Muskovac, FPSA (previously ran a Digital Salon):

Matt Muskovac (Software Programmer):

DONATION
Although these programs are free, a one time donation of $50 would be appreciated. Use the programs for your Salon 
first to be sure they meet your needs. 

The compiler used to create the programs will need to be upgraded soon for compatibility with future Windows 
operating systems. The latest version of the compiler is $900 ($US). My home programming is a hobby and doesn’t 
generate any other income.

Go to PayPay.com and “send money” to:

Or, if you are in the US:  Matt Muskovac, 1694 El Tair Trail, Clearwater, FL 33765  (US checks only please) 

WARRANTY
These programs are provided as-is without any warranty. 
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GENERAL OPERATION

Salon Setup (before listing Salon)

1. Obtain approval to have a digital salon from the PSA-EID division. You may also wish to get FIAP patronage. You 
will get many more foreign entries if you have FIAP patronage. 

2. Obtain an Email address and website capability. A separate email address for the Salon is recommended. Most 
Internet Service Providers will allow several email addresses at no extra cost.

3. Set a closing date for the Salon. Allow at least 2 months to create entry rules and a digital salon website (could be 
less after the first year). Allow 6-7 more months for the salon to be listed in the PSA journal. Closing date must be 
one week prior to judging according to PSA rules.

4. Create entry form on website. See separate entry form instructions. Entry form MUST produce output conforming 
to the instructions in the Salon Entry Form section. This is VERY important.

5. Write entry rules. Post on website. Using an Adobe Acrobat PDF file for the entry rules is highly recommended. 
There is no other format that is as universally readable as a PDF file.

Salon Listing

1. Submit Salon to PSA journal for listing. The listing must contain the website URL since people will be entering via 
the Internet. Please do not submit your salon for listing until you have created an entry form and tested it 
thoroughly. 

Collect Entries (before Closing Date)

1. When a person submits the entry form via the Internet, the entry data and images will be posted on your Server. As 
entries are received, copy them to your computer. Put the Entry Files and Images into the same folder. If duplicate 
entries occur (your computer will ask to overwrite), examine them to be sure you keep the correct one. Contact the 
entrant if necessary.

2. Add any notes to the entry using "Notepad". Notes can be used to indicate a problem with the entry (missing files, 
corrupt files, etc.).

3. As Entry Fees are received, open the matching entry file with Notepad and indicate that the person has paid.
4. Run the Collator program at least once a week before judging.
5. Create a “Status List” and use it to update the Web Site Status page.
6. Run the Salon Viewer program, open the “Image List” and test the images. Note problems with any images on a 

piece of paper and later add the problem to the note line of the Entry File using Notepad.

Prepare for Judging (after Closing Date)

1. Run the Collator program.
2. Create a “Status List” and use it to update the Web Site Status page. This is the last time the Web Site Status page 

should updated.
3. Note any Entrants that have not paid. Remove their Entry files and images from the folder.
4. Run the Salon Viewer program, open the “Image List” and test the images. Note problems on a piece of paper and 

later edit the Entry File to fix the problem if possible. Last resort, edit the Entry File and remove the bad 
title/filename.

5. After all problems have been fixed, run the Collator program and make a final “Image List” to be used for judging. 
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Judging Day – Manual Score Entry

1. Two computers are required on judging day. 
2. On the first computer, run the Salon Viewer program. This computer will display the images. An LCD projector is 

recommended.
3. On a second computer, run the Salon Scorer program. This computer will be used to enter the scores. 
4. Score all images in the first section.
5. Break ties if necessary to get an appropriate number of Acceptances and Honorable Mentions.
6. Select medals.
7. Repeat for each section.

Judging Day – Electronic Score Entry

1. If a compatible electronic judging system is used, only one computer is required on judging day. There are two 
compatible scoring systems: 1) H-ITT infrared clickers. 2) RMF model 750 judging system. With either of these 
systems, the judges’ scores will be input directly into the database. See special instructions at the end of this 
document.

2. Run the Salon Viewer program (version 2.0 or later). This computer will display the images. An LCD projector is 
recommended.

3. Score all images in the first section.
4. Break ties if necessary to get an appropriate number of Acceptances and Honorable Mentions.
5. Select medals.
6. Repeat for each section.

Make Reports (within one week of Judging)

1. Run the Salon Report program.
2. Create an Email Manual Report file.
3. Create an Email Merge Data file.
4. Create an Acceptance Table Report file.
5. Create an Acceptance Text Report file.
6. Create a Statistics Report file.

Email Results Report Cards (within one week of Judging)

Manual Method

1. Copy and paste each person's information from the Email Report to an email program and send.

Email Merge Method

1. Open the Email Merge Report Card.doc file.
2. Use the Mail Merge function to insert the email merge data.
3. Send the emails.

Post Results on Webpage (within one week of Judging)

1. Run the Salon Image Prep program.
2. Save the reduced images.
3. Run the Salon HTML program.
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4. Save the HTML pages.
5. Create top-level web pages manually and link them to the index pages.
6. Post pages on website.

Email Results to EID Star Ratings Director 

1. Run Microsoft Excel and open the Acceptance Table Report file.
2. Save it as an Excel file (.XLS).
3. Email it to the Star Ratings Director.

Make Slideshow (optional)

1. Run the Salon Slide Show Prep program.
2. Save the prepared images.
3. Use a slide show program (not included) to create a slide show from the prepared images. 

Make CD catalog (Within 2 months of Judging)

1. Use a webpage editor to make top-level HTML pages.
2. Copy the Statistics Report into one of the top-level HTML pages.
3. Put HTML pages and slideshow on CD. 
4. Proofread and test the CD several times (on several different computers if possible).
5. Make copies of the CD.
6. Make mailing labels (from the Collator program).
7. Mail CDs.
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Salon Data Flow:
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DETAILED INSTRUCTIONS

A flowchart of the Salon data flow is shown on the previous page. Referring to this chart may help you understand how 
the programs interrelate.

When you run the programs, some of them will display sequential red numbers to guide you through the program. Once 
you are familiar with the programs, these numbers will help you use the programs without constantly referring to the 
instructions. These red numbers do not correspond to the numbered instructions.

Note: Some of the programs refer to the sections as numbers (1, 2, 3, …) instead of letters (A, B, C, …). We 
recommend that the entry rules refer to the letters only.

When the programs are opening files, it may take 20 seconds or more depending on the size of the files and the speed of 
your computer. The programs will indicate that they are processing the data with an hourglass cursor.

ENTRY RULES

The Entry Rules must follow the EID Exhibition Standards (the 2002 standards are included). They also MUST be 
written with these programs in mind. See the example Entry Rules (Sample Entry Rules.pdf) in the Sample Entry Rules 
and Forms folder. 

A large percentage of our time running the salons has been spent dealing with irregularities. Many people do not exactly 
follow the entry rules. Sometimes it is due to carelessness, other times it may be due to inexperience with computers. 
Well-written entry rules will minimize mistakes. The most common mistakes is that people enter images that are larger 
than allowed by the Salon. Therefore, your Entry Form webpage should check the image size.

See the separate instructions for Entry Forms. 

We suggest that you try to make the entry cost less than a slide salon to encourage more people to start entering digital 
salons. The cost of a digital salon should be lower because you do not have the cost of returning slides.
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INTERNET ENTRY FORM

The Entry Form is filled out by each Entrant on the website. When a person submits the entry form via the Internet, the 
data in the form and the images will be uploaded to the Server. If the form was setup correctly the entry data text file 
will look similar to the table on the next page. A suite of entry form webpages is included in the Sample Entry Forms 
folder. These were created by the late Wade Clutton with the help of a professional web designer. I have edited them to 
make them easier to use. See separate instructions for using the entry forms. 

The entry form MUST produce output conforming to the table below. The “T” numbers MUST match the descriptions 
below. This is VERY important. The Collator program will assume the data is as described below. If it does not match 
you will have a disaster. Please test the form well before making it available to the public.

Entry Data File Format and Example:

FORMAT EXAMPLE
T1: Surname/Family Name
T2: Given Name
T3: Honors
T4: Address1
T5: Address2
T6: City
T7: State/Province
T8: Zip/Postal Code
T9: Country
T10: Email
T11: Special Data (was previously PSA 
Membership Number)
T12: Comments/Special Instructions
T13: Section A, Image #1 Filename
T14: Section A, Image #1 Title
T15: Section A, Image #2 Filename
T16: Section A, Image #2 Title
T17: Section A, Image #3 Filename
T18: Section A, Image #3 Title
T19: Section A, Image #4 Filename
T20: Section A, Image #4 Title
T21: Section B, Image #1 Filename
T22: Section B, Image #1 Title
T23: Section B, Image #2 Filename
T24: Section B, Image #2 Title
T25: Section B, Image #3 Filename
T26: Section B, Image #3 Title
T27: Section B, Image #4 Filename
T28: Section B, Image #4 Title

[Continue the sequence for up to 6 sections]
[Section C would be T29-T36]
[Section D would be T37-T44]

[Note: the following is added manually]
T90: Paid Status

T91: Notes

T1: Smith
T2: John
T3: 
T4: 1980 Smith Ave.
T5:
T6: Orlando
T7: Florida
T8: 34668
T9: USA
T10: jsmith@cybernet.net
T11:

T12: 
T13: smith-j-1234-A1.jpg
T14: Tailed Jay
T15: smith-j-1234-A2.jpg
T16: Painted Lady
T17: smith-j-1234-A3.jpg
T18: Owl Eye
T19: smith-j-1234-A4.jpg
T20: Monarch
T21: smith-j-1234-B1.jpg
T22: Bottled Butterfly
T23: smith-j-1234-B2.jpg
T24: Venus Butterfly Trap
T25: smith-j-1234-B3.jpg
T26: Swallowtail Umbrella
T27: smith-j-1234-B4.jpg
T28: Giraffe With Hat

T90: Yes

T91: 4 Color - Open, 0 Color - Landscapes, 0 Nature
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SALON COLLATOR PROGRAM

This program takes the Entry Files and combines them into three master lists. It is designed to accept input from an 
Internet website “form”. The data MUST be in the format described in the Internet Entry Form section. Sample entry 
files are included in the Sample Entries and Images folder.
 
This program takes the Entry Files from each entrant and produces three output files:

1. Status List – used to post entry status on your webpage.
2. Mail List – used to make mailing labels.
3. Image List – used for judging.

U.S. state names will be automatically converted to the standard 2-letter abbreviation for consistency. Variations of 
“United States” will be automatically converted to “USA”. 

Instructions

1. Run the Salon Collator program.
2. Select the total number of Sections (General, Creative, etc.) in the Salon with the Sections menu. 
3. Use the File menu to open the Entry files. Select any one entry file and click “Open”. The program will 

automatically import all files that do not begin with an underscore “_”. Be careful not to keep any non-entry text 
files in this folder that do not begin with an underscore.  Note: how the files are selected is different from 
previous versions where you needed to select all files. Windows has a limit that only allows about 900 files to 
be selected by the user. This caused a serious problem in very large Salons.

4. Manually check the file for obvious problems by scrolling through the entries.
5. Click the “Status List” tab.
6. Click the “Sort” button. This will sort the Entrants alphabetically.
7. Use the File menu to save the Status List.
8. Click the “Mailing List” tab.
9. If you are mailing from within the USA, check the “Omit USA” box.
10. Click the “Sort” button. This will sort the Entrants alphabetically by country.
11. Use the File menu to save the Mailing List.
12. Click the “Image List” tab.
13. Click the “Sort” button. This will sort the Images by section and round with the images in each round randomly 

distributed.
14. Use the File menu to save the Image List.
15. Exit the program.

Note: the instructions above assume you need all three output files. If you do not, you can omit saving the output lists 
you do not need.

Warning: Be very careful if you open the Image List file with Notepad or another word processor. The file can 
be easily corrupted if any of the tabs are deleted. If you open the image list with Excel, DO NOT re-save it as a 
text file. Excel will not include tab characters for empty fields and the file will be corrupted beyond repair.
 

Status List File 

The Status List is used to tabulate the status of the entries. It should be posted on the Website every week to allow 
entrants to check the status of their entries. The Status List is a simple HTML file that contains one Entrant per line in a 
table with the following information:

Name Place Paid Notes

Name = Surname, Given Name, Photo Honors
Place = City, State, Country
Paid = Exactly what is in the entry file (after T90:).
Notes = Exactly what is in the entry file (after T91:).
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Mailing List File Format

The Mailing List must be opened with a separate program to make mailing labels for the Salon Results CD. The 
program that makes the mailing labels is not included, but many commercial programs are available. Any program with 
a “mail merge” function will probably work. The Mailing List contains one Entrant per line with the following fields 
separated with Tabs:

Name Address1 Address2 City, State, Zip Country

Name = GivenName Surname, Photo Honors; combined from entry file fields
Address1 = Street address from entry file
Address2 = Optional
City, State, Zip = Combined from entry file fields 
Country = Same as entry file unless “USA” and “Omit USA” option was selected, then blank. 

Image List File Format

The Image list is used by the “Salon Viewer” program for judging and the “Salon Scorer” program for scoring. The 
images are sorted into Sections and Rounds with the images in each round randomly distributed. The Image List 
contains one image per line with the fields shown below separated with Tab characters. The number of characters 
allowed in each field is shown in parenthesis. *Note that although the title can be 50 characters it is recommended to 
limit this to 35 on your entry form. 35 characters has become the accepted standard among Salons, also longer titles 
may not fit well in the programs that display the titles.

Image #  (5)
Title  (50)*
Score  (3)
Tie Break 1  (8)
Tie Break 2  (8)
HM/Award  (36)
Section  (4)
Round  (4)
Image Filename  (36)
Entry File Filename  (36)
Surname  (36)
Given Name  (36)
Photo Honors  (36)
Address1  (36)
Address2  (36)
City  (36)
State/Province  (36)
Zip  (20)
Country  (36)
E-Mail  (50)
Special options (was PSA Membership #)  (20)
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SALON VIEWER / SALON SCORER PROGRAM (Manual Score Entry)

Follow the instructions in this section if you are entering the scores on a separate computer. If you are using a 
compatible scoring system that allows scores to be input directly, see the next section.

Since these programs are used together, the instructions are combined.

The Salon Viewer program is used to display the images for judging. The Image List file created by the Collator 
program contains the list of images to be judged. All of the images must be in the same directory as the Image List file. 
This will be referred to as the “Viewing” computer. The maximum image size is normally 1024 x 768 but can be 
changed in the options.

The Salon Scorer program is used to enter the scores in the Image List file on a second computer. The images do not 
need to be on the second computer. This will be referred to as the “Scoring” computer.

The images files should be tested with the Salon Viewer before judging to ensure none of them are corrupt. A common 
problem is for entrants to add an extra “.jpg” to their filenames (because they have “show file extensions” disabled in 
their Windows options). The Viewer will check for this condition and still find the file. The “Verify Size” box should 
also be checked during testing. If an image is too large the program will note them on the Errors Window.

Judging day is the most critical day. You may have judges from far away and other time constraints. Please practice 
using the Viewing and Scoring programs before judging day. If you run into problems using the programs you may 
have impatient judges or may not be able to complete the judging.

The “index” number always refers to the order in which the Salon Viewer will display the images. Therefore, the 
“index” number of an image will change when the images are sorted. The “image” number is assigned to each image by 
the Collator program and will not change when the images are sorted. Therefore, the “image” number of an image will 
remain the same during judging.

Instructions

1. Viewing computer: Put all of the Salon images into one folder along with the Image List file. (They should already 
be in the same folder if you followed the Collator instructions)

2. Viewing computer: Run Microsoft Excel and open the Image List file. If Excel asks how the fields of data are 
separated, select "tab delimited". Adjust the print area to include only the 7 leftmost columns. Make the rows wide 
enough to allow scores to be written in the Score column. Print the list. During judging scores should be written 
onto this list as an emergency backup. Quit Excel (do not Save).  An alternate method is to use the Salon Scorer 
program to enter backup scores on a third computer.

3. Scoring computer: Copy the Image List to the Scoring computer if necessary (using a removable disk or a 
network).

4. Scoring computer: Run the Salon Scorer program.
5. Scoring computer: Use the File menu to open the Image List file.
6. Steps 7-9 may be skipped if you are judging section 1 (A) and the images are already sorted with section 1 first.
7. Scoring computer: Use the Data menu to sort the images by the section you are preparing to judge. Sort: 1) Section, 

2) Image Number. Note: the images were randomized when the original Image list was created, randomizing again 
is not normally necessary.

8. Scoring computer: Use the File menu to Save the sorted Image List. Recommend filename: “_Image List 
Scored#.txt”), where # is incremented each time significant changes are made.

9. Copy the sorted Image List (saved in step 8) from the Scoring computer to the Viewing computer (using a 
removable disk or a network).

10. Viewing computer: Run the Salon Viewer program.
11. Viewing computer: Setup the maximum image size using the Options Menu. Most people will use the first option. 

We recommend 1024 x 768 (assuming your projector supports this size). Use the second option when you want to 
keep the maximum horizontal size the same as the maximum vertical size. Some people don’t want horizontal 
images to have an advantage; however, this option will reduce the usable area of your projector. If you use this 
option, the “Largest” pixel size must be less than or equal to the smallest dimension of your projector.

12. Viewing computer: On the Scoring pull-down menu, select: “Separate Computer”.
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13. Viewing computer: Use the File menu to open the Image List file.
14. Viewing computer: Set the RANGE of slides to display. If the Salon contains more than one section the RANGE 

should include the first and last slide of the section you are judging. Optional: you can right click on the row you 
want to select as the start or end.

15. Viewing computer: Set the “Advance” option to manual for judging. The option may be set to automatic advance 
for testing or previews.

16. Viewing computer: Click “Show”.
17. Viewing computer: For each image, wait for the judges to score, and then press the forward arrow key or “Enter” 

key to advance to the next image. The space key can be used at anytime to display the image number and title. This 
is normally done every 30 or 40 images to be sure the scores correlate with the images. Pressing the space key 
again will remove the information. The title should only be shown after an image is judged so as not to influence 
the judges scoring. The back arrow can be used to re-score an image if necessary. The Escape key is used to end the 
judging session before the end.

18. Scoring computer: Enter the scores in the “Score” column.
19. Repeat steps 17 and 18 until all images in the section are scored. Periodically save the file to minimize data loss if a 

power outage or hard disk crash occurs. Recommend filename: “_Image List Scored#.txt”, where # is incremented 
each time significant changes are made. Using different filenames will give you many backup files to choose from 
if the Image List file becomes corrupted.

20. Scoring computer: If this is the first pass of scoring for this section, sort the images by Section and Score. If you are 
breaking ties, you will normally sort by Section, Score and Tie Break 1. See other options for tie break sorting on 
the next page.

21. Scoring computer: Find an appropriate acceptance score by analyzing the data. See exhibition standards for the 
required range (normally minimum 25%). If an acceptable percentage of acceptances does not exist, some images 
may have to be re-scored to break the ties. Note any ranges of scores that must have ties broken.

22. Scoring computer: Find an appropriate Honorable Mention range by analyzing the data. See exhibition standards 
for the required percentage (normally minimum of 10% of accepted images). Put “HM” in the HM/Award column 
for those images that definitely qualify. Note any ranges of scores that must have ties broken.

23. Scoring computer: Note which images may qualify for medals. If any Medals are obvious based on the scores, note 
them in the HM/Award column. The text must start with “Medal” so the Salon HTML program can find the 
medals (if you have other non-medal special awards (e.g. ribbons) that you will want listed at the top of your 
results webpage, enter “Medal” temporarily and manually change it later). Note which images must be re-scored to 
narrow down the list to the available awards.

24. Scoring computer: Save the file using the File->"Save Image List …” command. Name the file differently than the 
original image list (recommend “_Image List Scored#.txt”, where # is incremented each time significant changes 
are made). 

25. Copy the scored Image List file (saved in step 24) from the Scoring computer to the Viewing computer (using a 
removable disk or a network).

26. Viewing computer: Use the “File” -> Open command to open the scored file.
27. Viewing computer: Set the range to a range of images that need ties broken.
28. Viewing computer: Click “Show”.
29. Viewing computer: For each image, wait for the score, then click the forward arrow or “Enter” to advance to the 

next image. See step number 17 for other options.
30. Scoring computer: Input the scores in the “Tie Break 1” column. “In/Out” judging is normally used for tie-breaks 

(1 or 0 by each judge). Write the total number of “Ins” scored in the Tie Break 1 column (0, 1, 2, or 3).
31. Scoring computer: Sort the images (normally by Section, Score, and Tie Break 1).
32. Repeat steps 27-31 for each range of scores that need to have ties broken.
33. After all tied images have been re-scored, write the appropriate information in the HM/Award column (or add one 

to the score if increasing acceptances). If necessary repeat steps 20-32.
34. Repeat steps 7-33 for each section.
35. Scoring Computer: When the judging is complete and all HMs and Medals have been entered, save the final file: 

“_Image List Scored Final.txt”. The way the images are sorted is not important at this point; the other programs that 
will use this data will sort as necessary.

36. Exit both programs.

If you exit the Scoring program before judging is complete for any reason, you must open the latest scored image list 
when you re-run the Scoring program. All of the scores for all sections must be in the same file when judging is 
complete. 

Other tie-break methods:
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We have found that committees and/or judges use many different techniques for tie-breaks and run-offs. We have tried 
to make the Salon Scorer versatile enough to handle many different techniques. The program can sort on multiple 
columns, sorting by scores or arbitrary numbers to allow grouping. Tie breaking can be tricky; we suggest practicing 
with the sample files.

Example: Two images score 26 points, five images score 25 points, and all others score lower. The judges wish to 
consider the top 7 for best-of-show. Sort by 1) Section, 2) Score. Put a "10" in the Tie Break 1 column for these 7 
images. Score in/out for these 7 images putting the in/out total in the Tie Break 2 column. Sort on 1) Section, 2) Tie 
Break 1, 3) Tie Break 2. For those images still in the running, change the "10" to an "11" and delete the in/out scores. 
Score in/out again if necessary. Sort again. For those images still in the running, promote the "11" to a "12". Continue 
the process until only one remains.
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SALON VIEWER (Automatic Score Entry)

Follow the instructions in this section if you are using a compatible scoring system that allows scores to be input 
directly. If you are entering the scores on a separate computer, see the previous section.

The Salon Viewer program is directly compatible with two electronic scoring systems. 1) H-ITT CRS infrared clickers. 
2) RMF model 750 judging system. If one of these systems is used, the Salon Scorer program and a second computer 
are not needed. See separate sections near the end of this document for the setup of these scoring systems.

The Salon Viewer program is used to display the images for judging and to input the scores. The Image List file created 
by the Collator program contains the list of images to be judged. All of the images must be in the same directory as 
the Image List file. The maximum image size is normally 1024 x 768 but can be changed in the options.

The images files should be tested with the Salon Viewer before judging to ensure none of them are corrupt. A common 
problem is for entrants to add an extra “.jpg” to their filenames (because they have “show file extensions” disabled in 
their Windows options). The Viewer will check for this condition and still find the file. The “Verify Size” box should 
also be checked during testing. If an image is too large the program will note them on the Errors Window. 

Judging day is the most critical day. You may have judges from far away and other time constraints. Please practice 
using the Viewing program before judging day. If you run into problems using the programs you may have impatient 
judges or may not be able to complete the judging.

The “index” number always refers to the order in which the Salon Viewer will display the images. Therefore, the 
“index” number of an image will change when the images are sorted. The “image” number is assigned to each image by 
the Collator program and will not change when the images are sorted. Therefore, the “image” number of an image will 
remain the same during judging.

Instructions

1. Put all of the Salon images into one folder along with the Image List file. (They should already be in the same 
folder if you followed the Collator instructions)

2. Run Microsoft Excel and open the Image List file. If Excel asks how the fields of data are separated, select "tab 
delimited". Adjust the print area to include only the 7 leftmost columns. Make the rows wide enough to allow 
scores to be written in the Score column. Print the list. During judging scores should be written onto this list as an 
emergency backup. Quit Excel (do not Save).  An alternate method is to use the Salon Scorer program to enter 
backup scores (use a numeric keypad). This requires someone who can type numbers quickly. 

3. Run the Salon Viewer program.
4. Setup the maximum size in the Options menu. Most people will use the first option. We recommend 1024 x 768 

(assuming your projector supports this size). Use the second option when you want to keep the maximum 
horizontal size the same as the maximum vertical size. Some people don’t want horizontal images to have an 
advantage; however, this option will reduce the usable area of your projector. If you use this option, the “Largest” 
pixel size must be less than or equal to the smallest dimension of your projector.

5. Select the appropriate scoring system from the pull-down menu (H-ITT IR Clickers or RMF System 750).
6. Setup the scoring system using the Options menu. The program will remember the previous settings for the H-ITT 

system. The RMF System 750 must be programmed each time the Salon Viewer is run. See separate sections at the 
end of this document for details on setting up the scoring systems.

7. Use the File menu to open the Image List file.
8. Step 9 may be skipped if you are judging section 1 (A) and the images are already sorted with section 1 first.
9. Use the Data menu to sort the images by the section you are preparing to judge. Sort: 1) Section, 2) Image Number. 

Note: the images were randomized when the original Image list was created, randomizing again is not normally 
necessary.

10. Set the RANGE of slides to display. If the Salon contains more than one section the RANGE should include the 
first and last slide of the section you are judging. Optional: you can right click on the row you want to select as the 
start or end.

11. Set the “Advance” option to manual for judging. The option may be set to automatic advance for testing or 
previews.
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12. Select “Score” from the Scoring pull-down menu.
13. Click “Show”.
14. For each image, wait for the judges to score. After they have scored; the image number, title, and score will appear 

on the Salon Viewer screen. Press the “Enter” key to record the score in the database or the “Esc” key to cancel the 
score (the text in the box will remind you which column the data will be entered into, be sure it is correct before 
recording the score). The space key can be used at anytime to display the image number, title, and judging status. 
This can be used to see which judges have scored if all of the judges seem to be waiting for the others. Pressing the 
space key again will remove the information. The back arrow can be used to re-score an image after it has been 
recorded if necessary. The Escape key is used to end the judging session before the end.

15. Repeat step 14 until all images in the section are scored. The “S” key can be used to access the save dialog without 
leaving the viewing mode. Periodically save the file to minimize data loss if a power outage occurs. Recommended 
filename: “_Image List Scored#.txt”, where # is incremented each time significant changes are made. Using 
different filenames will give you many backup files to choose from if the Image List file becomes corrupted.

16. If this is the first pass of scoring for this section, sort the images by Section and Score. If you are breaking ties, you 
will normally sort by Section, Score and Tie Break 1. See other options for tie break sorting on the next page.

17. Find an appropriate acceptance score by analyzing the data. See exhibition standards for the required range 
(normally minimum 25%). If an acceptable percentage of acceptances does not exist, some images may have to be 
re-scored to break the ties. Note any ranges of scores that must have ties broken.

18. Find an appropriate Honorable Mention range by analyzing the data. See exhibition standards for the required 
percentage (normally minimum of 10% of accepted images). Put “HM” in the HM/Award column for those images 
that definitely qualify. Note any ranges of scores that must have ties broken.

19. Note which images may qualify for medals. If any Medals are obvious based on the scores, note them in the 
HM/Award column. The text must start with “Medal” so the Salon HTML program can find the medals (if 
you have other non-medal special awards (e.g. ribbons) that you will want listed at the top of your results webpage, 
enter “Medal” temporarily and manually change it later). Note which images must be re-scored to narrow down the 
list to the available awards.

20. Save the file using the File->"Save Image List …” command. Name the file differently than the original image list 
(recommend “_Image List Scored#.txt”, where # is incremented each time significant changes are made). 

21. Set the range to a range of images that need ties broken.
22. Select tie break from the Scoring pull-down menu. Be sure the correct column is selected; otherwise the scores 

may be overwritten.
23. Click “Show”.
24. For each image, wait for the judges to score, then press “Enter” to record the score or “Esc” to cancel the score. See 

step number 14 for other options. “In/Out” judging is normally used for tie-breaks (1 or 0 by each judge). The total 
number of “Ins” will be recorded in the Tie Break 1 column (0, 1, 2, or 3).

25. Sort the images by Section, Score, and Tie Break.
26. Repeat steps 21-25 for each range of scores that need to have ties broken.
27. After all tied images have been re-scored, write the appropriate information in the HM/Award column (or manually 

add one to the score if increasing acceptances). If necessary repeat steps 21-25.
28. After each section is complete, save the image file to a removable disk for backup. If your hard-disk crashes, you 

can lose everything. 
29. Repeat steps 9-28 for each section.
30. When the judging is complete and all HMs and Medals have been entered, save the final file: “_Image List Scored 

Final.txt”. The way the images are sorted is not important at this point; the other programs that will use this data 
will sort as necessary.

31. Exit the program.

If you exit the Salon Viewer program before judging is complete for any reason, you must open the latest scored image 
list when you re-run the program. All of the scores for all sections must be in the same file when judging is complete
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SALON REPORT PROGRAM

The Salon Report program is run after the judging is complete. Scores, HM, and Medal information must be entered 
into the Image List file prior to this program being run. Only the first 5 characters of the HM/Award column will be put 
in the reports. 

The Salon Report Program creates 6 different reports:

1. Email Manual Report – creates a large text file containing all report "cards". See next section. 
2. Email Merge Data – creates a file containing report card data for an email “mail merge”. See next section. 
3. Scores HTML Report – this can be ported on a webpage instead of emailing “report cards” individually.
4. Acceptance Table Report - a simple table with the section, name, title, and entrant’s city/state/country for each 

accepted image. It should be emailed to the EID Star Rating Director. 
5. Acceptance Text Report - an acceptance list in the traditional format found in printed salon catalogs. 
6. Statistics Report - contains statistics by country for the Salon.

Instructions

1. Run the Salon Report program.
2. Use the File menu to open the scored Image List file (_Image List Scored Final.txt).
3. Click on the "Report Options" tab.
4. Enter the name, code, and the minimum score for acceptance for each section. The code is optional and is only used 

for the Acceptance Text Report.
5. Edit the Email report box: enter the Salon name and edit any other information necessary.
6. If you are making an Acceptance Text Report, select options for the report.
7. Click on the "Email Manual Report" tab and then click the “Make Report” button.
8. Use the File menu to save the Email Manual Report.
9. Click on the "Email Merge Data" tab and then click the “Create Merge Data” button.
10. Use the File menu to save the Email Merge Data.
11. Click on the "Scores HTML Report" tab and then click the “Make Report” button.
12. Use the File menu to save the Scores HTML Report.
13. Click on the "Acceptance Table Report" tab and then click the “Make Report” button.
14. Use the File menu to save the Acceptance Table Report.
15. Click on the "Acceptance Text Report" tab and then click the “Make Report” button.
16. Use the File menu to save the Acceptance Text Report.
17. Click on the "Statistics Report" tab and then click the “Make Report” button.
18. Use the File menu to save the Statistics Report.
19. Exit the Report program.

Note: the instructions above assume you need all six report files. If you do not, you can omit saving the reports you do 
not need.

Some people feel that posting all scores on a webpage is not appropriate because it may embarrass people with low 
scores. But, since many Exhibitions have been posting the scores anyway, I have included a Scores report to make it 
easier.
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EMAIL REPORT "CARDS"

There are two methods to create report cards. The manual method is very time consuming, but it will work with any 
computer. The Email Merge method is much faster, but it is more complicated and requires that you have software 
capable of doing an email “mail merge”. If you have Microsoft Word 2002 (or later) and Microsoft Outlook, you 
probably have this capability.

Email Manual Report Method:
Instructions

The Salon Report Program must be used first to create an Email Manual Report.

1. Open the Email Report with Notepad or a word processor.
2. Open your email program. 
3. Select "new" message.
4. Copy one email address from the email report and paste it in the address line of your email program.
5. Copy the subject from the email report and paste it into the subject line of your email program.
6. Copy the results for one person from the email report and paste it into the message area of your email program.
7. Send the email.
8. Repeat steps 3-7 for each entrant.

This will take about an hour or two for each 100 entrants you have. This is still much easier than filling out report cards 
by hand.

Email Merge Data Method:
Instructions

The Salon Report Program must be used first to create Email Merge Data. You must also have an email “mail merge” 
capability to use this method. These instructions assume you have Microsoft Word 2002 and Microsoft Outlook. Other 
programs may work, but the procedure will be different. If you cannot get this method to work, you can always use the 
manual method above.

1. Open the “Email Merge Report Card.doc” file with Microsoft Word. This file already contains the mail merge 
fields.

2. If the program asks where the data is, browse and select the “_Email Merge Data.txt” file created by the Report 
Program.

3. Edit the Salon name, webpage information, and add any other comments you would like to send to everyone. The 
areas indicated with “<<  >>” will be used by the mail merge to insert each person’s data. Do not edit these areas 
unless you are sure you know what you are doing.

4. Select the “Mail Merge Wizard …” menu option in Microsoft Word (under Tools, Letters and Mailings).
5. Follow the steps indicated by the wizard. Use the preview option to verify the report cards are correct.
6. When you are sure the report cards are correct, complete the last step and all of the emails will be sent. Check the 

“Sent Items” folder in Microsoft Outlook to verify that the emails were sent. Warning: be careful when testing, one 
click can send a lot of emails.
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EMAIL RESULTS TO STAR DIRECTOR

The Salon Report Program must be used first to create an Acceptance Table Report.

Instructions

1. Run Microsoft Excel and open the Acceptance Table Report. If Excel asks how the fields of data are separated, 
select "tab delimited".

2. Save it as an Excel (.XLS) file.
3. Email the file to the EID Star Ratings Director. 

SALON STATISTICS

The Salon Report Program must be used first to create a Statistics Report.

Instructions

1. Run Microsoft Excel and open the Statistics Report. If Excel asks how the fields of data are separated, select "tab 
delimited".

2. Manually fix any inconsistencies in the countries. For example, some people may have entered as "U.K." and 
others may have entered as "England". You probably will want to combine these.

3. Save the file as an Excel (.XLS) file.
4. Copy the table into one of the top-level HTML results pages using your webpage editor.
5. Modify the table to suit your tastes.
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SALON IMAGE PREP PROGRAM

The Salon Image Prep program is used to resize and add a copyright notice to the images so the Salon HTML program 
can use them. Scores must be entered into the Image List file with the Salon Scorer (or Salon Viewer) program prior to 
this program being run.

Instructions

1. Run the Salon Image Prep program.
2. Use the File menu to open the scored Image List file (_Image List Scored Final.txt).
3. Sort either by name or country depending on how you want the accepted images listed.
4. Click on the "Acceptance List" tab.
5. Select a section.
6. Enter the minimum acceptance score for the selected section.
7. Click "Make List".
8. Click on the "Setup" tab.
9. Enter the jpeg compression quality. 70 or 80 are recommended. 
10. Enter the reduced image sizes. We use 550 x 450 for all images on the CD. We use 550 x 450 for images winning 

medals on the Internet and 400 x 400 for accepted images on the Internet.
11. Use the File menu to save the reduced images. The reduced image filenames will be automatically generated with 

the following filename format: i_Y_XXXX.jpg, where Y is the section number and XXXX is a sequential number. 
This can take 2-20 minutes or longer depending on the speed of your computer and the number of acceptances. The 
reduced files will be put in a folder named “Html” inside the folder that contains the image list (this is a 
change from previous versions of the program).

12. Repeat steps 4-11 for each section.
13. Exit the program. (do not move the images until you have made the HTML pages)
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SALON HTML PROGRAM

The Salon HTML Program is used to create HTML pages for either the Internet or an HTML catalog for a CD. All of 
the accepted images with names and titles are linked with index pages automatically. Examples of the program output 
are included in the Sample HTML folder.

Putting the salon results on the Internet allows people to see the results very quickly. It does not take much time. We 
were able to do it the same day the salon was judged.

Scores, HM, and Medal information must be entered into the Image List file with the Salon Scorer (or Salon Viewer) 
program prior to this program being run. The Salon Image Prep program must also be run prior to this program.

Instructions

1. The data in the “HM/Award” column of the Scored Image List MUST have been previously entered exactly as 
follows for this program to function properly. For honorable mentions enter “HM”. For medals enter “Medal-
description”, where description is a description of the medal. Example: “Medal-Silver medal of merit”.

2. Run the Salon HTML program.
3. Open the scored Image List file ( _Image List Scored Final.txt ).
4. Sort either by name or country depending on how you want the list to appear. They MUST be sorted the same way 

they were sorted in the Image Prep program.
5. Click on the "Acceptance List" tab.
6. Select a section.
7. Enter the minimum acceptance score for the selected section.
8. Click "Make List".
9. Click "Get Image Sizes".
10. Click on the "Results Index Setup 2" tab. The "Results Index Setup 1" tab is for extremely advanced users only.
11. For each medal, enter the order in which you want it to appear in the medal list. Put a "1" in the order column for 

the medal you want first in the medal table. Put a "2" in the order column for the medal you want second in the 
medal table. Continue for all the medals. Do not skip any numbers.

Example:

MEDAL NAME ORDER
Medal - Judges choice Smith, John 5
Medal - Silver medal Jones, Robert 3
Medal - Judges choice Brown, Mary 6
Medal - Judges choice White, Mike 7
Medal - Best of show Cooper, Bill 1
Medal - Gold medal Campbell, Bob 2
Medal - Bronze medal Anderson, Julie 4

12. Click on the "Image Page Setup" tab.
13. Enter a shortened name for your Salon. Keep this short because it will appear on every HTML image page. 
14. Save the HTML using the File menu. The HTML files will be put in a folder named “Html” inside the folder 

that contains the image list (this is a change from previous versions of the program). The page filenames will 
be automatically generated with the following filename format: 

Section Index pages: sect_Y.htm 
Medal pages: m_Y_XXXX.htm 
Acceptance pages: a_Y_XXXX.htm 

where Y is the section number and XXXX is a sequential number.

15. Repeat steps 5-14 for each section.
16. Exit the program.
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17. Open each sect_Y.htm file by double clicking on it. Check the tables for content only; the format will be fixed later. 
Check the images links. Fix any minor problems manually. If there are major problems, edit the image list using the 
Salon Scorer program if necessary, then go back to step 1. 

18. Copy the three buttons (idxbutt.jpg, nextbutt.jpg, prevbutt.jgp) from the Sample HTML folder to the “Html” folder. 
You may make your own buttons to replace them, but they must have the same names and be the same size.

19. Using Microsoft Expressions Web or another webpage editor, create top-level web pages manually and link them to 
the section index pages. See sample file: "results.htm". The details of this procedure will depend on the webpage 
editor you are using.

20. Using Microsoft Expressions Web or another webpage editor, customize the section index pages (sect_Y.htm) by 
adding your salon title, custom graphics, etc. Add "up" links to return to the top-level pages. Warning: do not 
change the filename of the section index pages, the medal and acceptance pages link back to them.

21. Post (publish) all the HTML pages and reduced images from the Salon Image Prep program to the website and/or 
copy them to the CD catalog.

Note: To make the HTML links between files on a CD readable by a Macintosh, limit all your filenames to 8 characters 
+ the 3 character extension. The files made automatically by our programs follow this guideline. We recommend testing 
your CD on a Mac. About 5% of your entrants will have Macs. If your CD is not readable by a Mac, many entrants will 
be unhappy. These limitations do not apply to a website, only a CD.

All files on a PC are stored using short filenames; the long filenames on a PC are an illusion created by a translation 
table. A Mac can only see the short filenames. So, the individual files may be readable, but the links between files will 
not work if the names are long.

Example HTML File Links:

23 of 31       o

ETCjudges.htm committe.htm

results.htm

sect_1.htm sect_2.htm

m_1_XXXX.htm

a_1_XXXX.htm

m_2_XXXX.htm

a_2_XXXX.htm

Top-level, 
made with 
webpage 
editor.

Made 
automatically 
with HTML 
Program

Section 1 
 Index 
Pages

Medal Pages

Acceptance Pages

Section 2 
 Index 
Pages

Made 
automatically with 
HTML Program, 
then customized 
with webpage 
editor.



SALON SLIDE SHOW PREP PROGRAM

The Salon Slide Show Prep program is used to aid in the creation of a slide show of accepted images. The slide show is 
used for the two required public showings. The program will resize the images, add a copyright to the image, and add 
the maker's name and title. Scores must be entered into the Image List file using the Salon Scorer (or Salon Viewer) 
prior to this program being run. The size of the output files will default to 1024 x 768, but can be changed in the 
options. The size should match the resolution of the projector that will be used. Examples of the program output and a 
sample slide show (SampleSlideShow.exe) are included in the Sample Slide show folder.

Instructions

1. Run the Salon Slide Show Prep program.
2. Use the File menu to open the scored Image List file (_Image List Scored Final.txt).
3. Click "Sort".
4. Click on the "Acceptance List" tab.
5. Select a section.
6. Enter the minimum acceptance score for the selected section.
7. Click "Make List".
8. Click on the "Setup" tab.
9. Enter the Total Size and Accepted Image sizes. The Total size should be equal to the resolution of the projector or 

monitor that will be used to display the slideshow. Assuming your resolution is 1024 x 768, 850 by 750 is 
recommended for the Accepted Image size. Note: sizes much different than this will not work well. If your 
projector has a higher resolution, you will need to experiment.

10. Select a font and color. The default font (MS Sans Serif, 15 pt) and color (light gray) will produce pleasing results. 
They may be altered if you desire. Selecting a bright color is not recommended because it may clash with some 
images. Note: The background will be black; selecting a very dark color will make the text difficult or impossible 
to read.

11. Enter the jpeg compression quality. 70 or 80 are recommended. 
12. Use the File menu to save the reduced images. The reduced images will be saved with new filenames. The new 

filenames will have a prefix of “i_Y_” added, where Y is the section. The entrant's name and the title will be added 
to the image. This can take 5-30 minutes or longer depending on the speed of your computer and the number of 
acceptances. The reduced files will be put in a new folder named “SlideShow” inside the folder with the 
original images.

13. Repeat steps 4-12 for each section.
14. Exit the program.
15. Create the slide show using a separate program. ProShow Gold, available at Photodex.com is the recommended 

program (about $80). ProShow gold has an option to create DVDs that can be played on a TV (or Mac). Microsoft 
PowerPoint will also work, but it is cumbersome for this purpose.
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Using H-ITT Infrared Clickers (optional):

The program supports the use of H-ITT CRS infrared clickers. This allows the judges scores to be input directly into the 
program. The clickers must be the newer version with 13 keys. The system can be purchased at “h-itt.com”. Other 
infrared scoring devices are not supported. Note: The clickers are not recommended for large Salons. The buttons are 
small and can be difficult to press quickly. The RMF keypads are a better choice for large Salons.

Driver Installation:

You do not need to install the normal classroom software supplied by H-ITT to use the SalonViewer program. You do, 
however, need to install USB to COM Port VCP (Virtual COM Port) drivers. There are several ways this can be done. 
When you first connect the H-ITT base unit to your computer, you will get a “found new device” message. Option 1: 
The drivers for Windows 2000 and XP are included; tell Windows where the “FTDI USB COM Port Adapter 2000-XP” 
folder is located. Option 2: If your operating system is not 2000 or XP, you should go to the FTDI site and get the 
appropriate drivers. You only need to install the VCP drivers, the D2XX drivers are not needed.

http://www.ftdichip.com/Drivers/VCP.htm

You may need to restart your computer once or twice to complete the installation. To see if the driver installation was 
successful, go to Control Panels and open the System icon. Select the Hardware tab and click on Device Manager. 
These instructions may be slightly different if you are using an operating system other than XP. You should have a 
“USB Serial Port” entry under “Ports”. Note the COM number for the next step. 

If you are having problems, download the H-ITT software and follow the included instructions. Their instructions are 
more detailed. As a last resort, call H-ITT support. However, they will only help you get their software to work, not the 
SalonViewer software. But, once the H-ITT classroom software is working, the drivers will be setup correctly and the 
SalonViewer software should work. 

Clicker Setup:

Open the “Options” menu and select “Setup H-ITT Clickers …”. 
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“COM Port Setup” tab: The H-ITT system communicates with the SalonViewer software via a COM port. USB 
versions of the system have a USB to COM port converter inside them. From the SalonViewer software’s perspective, it 
is always a COM port. The software cannot determine which COM port is being used by itself, you must select the 
COM port being used. This can be done by noting which COM port is being used by the USB Serial Port adapter (see 
Device Manager instructions in the previous step), or by trial and error. If the driver is working and you have selected 
the correct COM port, the black box will move when you press any number key on any clicker. 

“IR Clicker Setup” tab: Each clicker has a unique code. The SalonViewer software must correlate the codes of the 
clickers to the position of each judge. Put an adhesive label on each clicker and number them 1,2,3. Press the “Program” 
button, and then click any number key on the corresponding clicker within 5 seconds. The box will flash green and the 
clicker code will appear in the box. Repeat for each clicker. The clicker codes will be saved in the “options” file, you 
only need to repeat this step if you change clickers or the options file changes.

 “IR Clicker Test” tab: The clicker labeled “1” should be on the left as you face the screen or print box. Test each 
clicker to make sure it correlates to the appropriate judge’s position on the screen. Then let the judges practice using the 
clickers. Instruct the judges to look for the green light at the top of their clicker when they enter a score. The base 
unit will send an infrared signal back to the clicker if the entry was recognized. If the judge does not see a green light, 
they should score again.

Judging Electronic Images:

When an image is shown for judging, the judges enter a score by pressing the appropriate number on their clicker. After 
all three judges have scored; each score along with the total will be displayed on the screen. Press “Enter” on the 
computer to accept the score or “Esc” to cancel the score. The word (score, tie brk1, tie brk2) before the score will 
remind you which column the score will be entered into. 

Pressing “Esc” when the score total is not displayed will cause the program to leave judging mode and return to the 
main window. Pressing the space bar will show which judges have entered their scores. A “#” will appear as each judge 
enters his or her score. If the judges are all waiting, this can be used to show them who still needs to enter their score. 
The “C” key on the computer can be pressed to clear the scores, although this is really not necessary because a judge 
can re-enter his or her score as long as it is done before all three have scored. The “S” key can be used to open the save 
dialog box without leaving judging mode.

Room Setup: 

USB cables can only be a maximum of 15 feet long. If you put the computer behind the projector, the USB cable will 
not reach to the front of the room where the base system should be located. We put the computer at the front of the room 
off to one side. We have an extra long monitor cable that goes to the projector.

If you really want the computer at the back of the room, there may be another option. Note, I have not tried this, I am 
assuming that the serial data at the base system is electrically compatible with a computer. Check with H-ITT before 
you invest in the extra equipment. Buy the optional AC adapter for the H-ITT system, a USB to COM port adapter 
(unless your computer already has a COM port), a long cat-5 modular cable with RJ-45 connectors at both ends 
(attaches to the base system), and a RJ-45 to 9 pin adapter (attaches to the computer or USB to COM port adapter). The 
base system will need separate power from the AC adapter because it normally gets power from the USB cable. 

Clicker Lighting:

The numbers on the clickers are not visible in a darkened room. The judges could memorize the positions of the 
numbers. Or, you can make lights for the clickers. I made brackets to hold small lights (see pictures). The light points 
up and reflects off the bottom side of the angled bracket. They can be made with a vice, hacksaw, and file. Paint the 
bracket with satin white paint. The brackets are functional, but they are not pretty. If you make something better, please 
let me know.

Buy small keychain LED lights with slide switches. I recommend red LEDs, white may be too bright and disturb the 
audience. Buy a few spares, they are not extremely reliable and the batteries take a while to change. Put adhesive Velcro 
on the bracket (hook side) and the keychain lights (loop/fuzzy side). Use rubber bands to attach them to the clickers.

http://freeled.com/reseller.html
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Using the RMF Model 750 Judging System (optional):

The program supports the use of the RMF model 750 judging system. This allows the judges scores to be input directly 
into the program. Windows XP or later is required. The system may be purchased on-line from RMF. 

http://www.rmfproducts.com/

Connect the keypads before you run the software. See the instructions that came with your RMF model 750 system. 
Wait until Windows recognizes all of the keypads, this may take up to 30 seconds. Most computers will show a message 
similar to the following when ready: “Your new hardware … is ready to use”.

RMF Keypad Setup:

Open the “Options” menu and select “Setup RMF 750 Keypads …”. 

“Keypad Setup” tab: Because Windows’ assignment of the keypads to numbers is not predicable; the keypads must be 
setup each time the program is run to correlate each keypad with the appropriate judge. Press the “Start Setup” button 
and follow the instructions on the screen. The keypad designated for judge 1 should be on the left as you face the 
screen. If a keypad stops working because it has lost its connection to the computer, run through the setup sequence 
again. Note: the number of keyboards/keypads found by the computer may be greater than the number of physical 
keyboards/keypads actually connected because Windows supports virtual keyboards.

Important: Be careful, keystrokes on the judge’s keypads will be interpreted by Windows the same as a regular 
keyboard/keypad unless the SalonViewer program is running and the keypad setup procedure has been followed. 
Pressing keys on the judge’s keypads may disrupt SalonViewer or any other computer program you are running. 
 
“Keypad Test” tab: Test each keypad to make sure it correlates to the appropriate judge’s position on the screen. Note: 
if the keypad has a “Num Lock” light, it must be illuminated on each keypad. Press the “Num Lock” key to put each 
keypad in number mode if necessary.

Judging Electronic Images:

When an image is shown for judging, the judges enter a score by pressing the appropriate number on their keypads. 
After all three judges have scored; each score along with the total will be displayed on the screen. Press “Enter” on the 
main computer keyboard to accept the score or “Esc” to cancel the score. The word (score, tie brk1, tie brk2) before the 
score will remind you which column the score will be entered into. 

Pressing “Esc” when the score total is not displayed will cause the program to leave judging mode and return to the 
main window. Pressing the space bar will show which judges have entered their scores. A “#” will appear as each judge 
enters his or her score. If the judges are all waiting, this can be used to show them who still needs to enter their score. 
The “C” key on the computer can be pressed to clear the scores, although this is really not necessary because a judge 
can re-enter his or her score as long as it is done before all three have scored. The “S” key can be used to open the save 
dialog box without leaving judging mode.
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Backup!

Hard drives are mechanical devices and can fail. Periodically copy important data files to a thumb drive or other storage 
device. This should be done when entries are being collected and on judging day. 

Projector Calibration

The included Test Gradient program can be used for a basic brightness calibration. When you execute the program, 
grayscale bars and focusing targets are displayed with a border. Click to exit the program.

Ideally, there should be distinct shades of gray between the black and the white. Few projectors will be able to 
accomplish this. The white side is more critical than the black side. You do not want the white band to merge with the 
almost white band.

Many projectors also need to have the horizontal position adjusted so the one pixel frame is equal on both sides. Our 
projector will cut off one pixel on a side if it is not adjusted. 

All entrants should submit their entries using the sRGB color profile. 
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OTHER IDEAS

Subsections within Sections (e.g. Wildlife in Nature)

If you have a Section where special awards are given to images that meet certain criteria (e.g. Wildlife in Nature 
division), here is one way to handle it. Have entrants prefix their image title with “(W)”, and then sort on the name field 
before selecting any special Wildlife awards.  

(W) Blue Heron
(W) Elephant
Tiger
Baboon

Remote Judging

The programs were not written with remote judging in mind. If you have any ideas on a remote judging procedure using 
the existing programs we would be interested in your ideas. We do not have the time or interest to do a major re-write 
of these programs to accommodate remote judging.
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